Ballads of Reemus & Several Journeys / Reemus 3 now has ClickShake Rewards
  1. SteveCastro says:

    Reemus Chapter 3 now has 2 new Reward achievements! Plus, the game play is streamlined by allowing screen exits to happen instantly instead of having to walk all the way across the screen each time!

    I know I skipped chapters 1 and 2 for Rewards, but #3 was crashing in the latest version of Flash so I had to fix that and decided to drop in some Rewards while I was at it.

    http://www.clickshakegames.com/reemus/several-journeys-of-reemus-3-know-thy-enemy.php

  2. darkbluemullet says:

    Great stuff Steve!

  3. jeltevl says:

    i found a bug that wasn't in reemus 3 before.
    When you first play the path of least resistance and then the last scene from the path of aggresion, liam have the royal looking letter stil in its hands.

  4. RickyTheFish says:

    Does Chapter 3 work on Newgrounds as well? I know the medals there have been broken for a while because the game was borked. I got the medals long ago, and I remember trying to replay the game and being unable to.

  5. JayZiebarth says:

    Yes, it should be working on NG again.

  6. beefsnarf123 says:

    i was playing the game at the start there was a ad then after it i pressed play

  7. crsunlimited says:

    Just found a bug while completing my path of aggression on Chapter 3. In the last room where you are mixing the drinks for the statues. When I switched to Remus and stepped on the 2nd (One on the right) Stone to get the 2nd set of colors I accidentally clicked on the left mouse arrow to go to the left instead of changing back to Leum.

    Because of the instant transfer Remus was transferred to the room on the left, and I noticed that the colored water was still running in the fountain even though Remus was not on the block now. I tried to step on the 2nd stone again and Remus told me that there was already someone there even though there wasn't, and said he doesn't like cuddling. So then I tried to fix the problem by stepping on the first stone again. This made the water change back to the first set of colored water in the fountain, but did not release the 2nd stone.

    Now I took Remus out of the room and the water was completely off in the fountain. However the 2nd stone stayed down, and the pipes behind the statue that show that the colored water is activated where still on. Once again he told me he didn't like cuddling and that he couldn't step on it.

    I accidentally tested this by doing the exact same mistake after I reloaded the page. Not sure if it will do this on the first stone as well if you make the mistake.

    Just to be crystal clear here: I had filled the left statues mug with Yellow and had Leum waiting by the fountain then switched to Remus and stepped on the 2nd block to change colors, then clicked on the left arrow which put Remus at the fountain by Leum.

  8. spookspoon says:

    woah, each time the glitches get weirder and weirder.

  9. CFS says:

    Hey, can anybody help me with the path of aggression? I'm color blind (yes, seriously) and can not tell some colors from others. So, can anybody please tell me the ORDER of the steps in the colored liquid level please? Being color blind, I never know which color or how many I got wrong, so trial & error won't work for me. Thank you!


Reply

You must log in to post.